Email send delays
Incident Report for Notarize
Resolved
We believe all critical emails are now being sent without delays. There is no customer impact at the moment. Notarize will continue monitoring the incident updates from the email provider, including a debrief on the root cause.
Posted Jul 28, 2020 - 14:16 EDT
Update
We are seeing some improvements in email delivery - critical emails are now being delivered. We are still actively monitoring the situation and assessing the impact on previously sent emails.
Posted Jul 28, 2020 - 13:38 EDT
Update
This issue is still ongoing, our vendor is reporting some progress in addressing it but no ETA for the final resolution. Notarize is working on workarounds to support order processing and allowing signers to access their transactions.
Posted Jul 28, 2020 - 13:17 EDT
Update
Update: the email send issue is still ongoing. Our email vendor posted "engineers are working on a fix" update but is unable to provide an ETA.
Posted Jul 28, 2020 - 11:24 EDT
Identified
We are tracking a major outage of our 3rd party email provider, which started approximately at 8 am Eastern time. Most of the emails sent by Notarize platform are being delayed as a result. We do not have an ETA on the fix from the vendor yet. Once the service is restored, all delayed emails will be automatically sent.
Posted Jul 28, 2020 - 09:25 EDT
This incident affected: Notarize Consumer (Web), Notarize API, Notarize Real Estate, and Notary Platform.