Signer ID verification issues: Third party vendor is experiencing issues with their service this impacted signer's ability to enter the meeting queue
Incident Report for Proof
Resolved
Our service provider has restored their services and we have switched back to this primary workflow.
Posted Dec 15, 2021 - 13:57 EST
Investigating
Signer ID verification issues: Third party vendor is experiencing issues with their service this impacted signer's ability to enter the meeting queue. This impacts users that were attempting to enter into a meeting with a notary during the time it took to switch to alternate paths.
Posted Dec 15, 2021 - 13:33 EST
This incident affected: Notarize Consumer App (iOS), Proof Consumer (Web), and Notarize Consumer App (Android).