Document finalization issue
Incident Report for Proof
Resolved
This issue is now resolved. Notary meetings are occurring and documents are being finalized.
Posted Oct 30, 2021 - 12:10 EDT
Update
We are continuing to monitor for any further issues.
Posted Oct 30, 2021 - 12:08 EDT
Monitoring
The system shows both meeting starts and document finalization tasks are operating normally. We continue to monitor the system for any residual effects.
Posted Oct 30, 2021 - 01:16 EDT
Update
The system shows both meeting starts and document finalization tasks are operating normally.
Posted Oct 30, 2021 - 01:06 EDT
Update
Software changes have been deployed to production and our initial monitoring of the system show that the document finalization tasks are completing normally.
Posted Oct 30, 2021 - 00:37 EDT
Update
Software changes are currently being tested to fix the certificate routing issues that have caused some notaries to be unable to start meetings and document finalization delays.
Posted Oct 29, 2021 - 23:42 EDT
Update
While the engineering team continues to investigate additional mitigation strategies to allow impacted notaries to enter meetings, the notary support team is also working with impacted notaries to individually resolve their issues.
Posted Oct 29, 2021 - 22:59 EDT
Update
The engineering team continues to investigate additional mitigation strategies to allow effected notaries to enter meetings.
Posted Oct 29, 2021 - 22:23 EDT
Update
While the investigation continues, a code change is being prepared to help further mitigate the certificate related failures.
Posted Oct 29, 2021 - 21:41 EDT
Update
Notarize and our certificate vendor are continuing to investigate the certificate verification issue. A subset of notaries continue to be available to start meetings.
Posted Oct 29, 2021 - 21:04 EDT
Update
Notarize and our certificate vendor are continuing to investigate the certificate verification issue. A subset of notaries continue to be available to start meetings.
Posted Oct 29, 2021 - 20:29 EDT
Update
Notarize and our certificate vendor are continuing to investigate the certificate verification issue.
Posted Oct 29, 2021 - 20:01 EDT
Update
Notarize and our certificate vendor have identified the potential source of the issue as being a loop in the certificate chain. When this validation error occurs, it will prohibit a notary from being able to start meetings. Some notaries continue to have access to the system and are able to complete meetings.
Posted Oct 29, 2021 - 19:30 EDT
Update
We and our certificate provider are continuing to investigate the issue.
Posted Oct 29, 2021 - 18:48 EDT
Identified
Notarize has identified this issue as stemming from one of our signing certificate providers. The provider has acknowledged and identified the issue on their end and is prioritizing a fix.
Posted Oct 29, 2021 - 18:08 EDT
Update
We are continuing to investigate the source of this problem. We are also investigating a short term fix that would allow notaries to connect to meetings as a first phase.
We'll continue to update status every 30 minutes or if there are any new updates worth reporting.
Posted Oct 29, 2021 - 18:02 EDT
Update
We have now identified that this issue is preventing notaries from connecting to meetings. We are continuing to investigate.
Posted Oct 29, 2021 - 17:32 EDT
Investigating
Notarize has become aware of a problem with the system used to finalize documents on our platform. Notary meetings should continue to function properly, but there will be a delay in receiving finalized documents. We are investigating and will continue to update.
Posted Oct 29, 2021 - 17:05 EDT
This incident affected: Notarize Consumer App (iOS), Proof Consumer (Web), Notarize Consumer App (Android), and Proof Real Estate.