Issue with Third Party Services
Incident Report for Notarize
Resolved
This incident has been resolved.
Posted Feb 17, 2022 - 15:51 EST
Monitoring
The third party service has reported that the issue is fixed. We are seeing that meetings are completed and payments are going through now and documents are available. We will continue to monitor to ensure the situation is fully handled.
Posted Feb 17, 2022 - 15:24 EST
Update
We are continuing to work on a fix for this issue.
Posted Feb 17, 2022 - 15:06 EST
Identified
The issue has been identified by the service provider and a fix is being worked on.
Posted Feb 17, 2022 - 15:05 EST
Investigating
Around 1:45 PM EST Notarize detected an issue with one or more of our third party services, which may be impacting payments for certain customers, finalization of meetings and receipt of notarized documents.

Our engineering team is investigating this issue and working with these third party services to resolve the issues ASAP. We will provide updates as soon as we have them.

When the service is back up, payments should go through as usual, meetings will be finalized and documents will be available.
Posted Feb 17, 2022 - 14:34 EST
This incident affected: Notarize Consumer App (iOS), Notarize Consumer (Web), Notarize Consumer App (Android), and Notarize Real Estate.