Delayed email sends
Incident Report for Notarize
Resolved
As of 4 pm Eastern time, the email service has been restored. Most of the delayed, high priority emails were already resent, and the remaining ones will be automatically resent in the next 30 minutes.
Posted Feb 24, 2021 - 16:17 EST
Identified
Starting 2:40 pm Eastern time, Notarize platform is experiencing delays in sending emails to our users, due to a 3rd party email provider partial outage. We are monitoring the situation and will provide an update in the next hour. We expect all emails will be sent out once the service is restored.
Posted Feb 24, 2021 - 15:43 EST
This incident affected: Notarize Consumer (Web), Notarize Real Estate, and Notary Platform.